Xposed框架介紹

  • 20
  • 26,120 views
  • A+
所屬分類:刷機準備
  • Xposed框架

Xposed框架是一款可以在不修改APK的情況下影響程序運行(修改系統)的框架服務,基于它可以制作出許多功能強大的模塊,且在功能不沖突的情況下同時運作。

Xposed,大名鼎鼎得Xposed,是Android平台上最負盛名的一個框架。在這個框架下,我們可以加載很多插件App,這些插件App可以直接或間接操縱系統層面的東西,比如操縱一些本來隻對系統廠商才open的功能(實際上是因為Android系統很多API是不公開的,而第三方APP又沒有權限)。有了Xposed後,理論上我們的插件APP可以hook到系統任意一個Java進程(zygote,systemserver,systemui)

功能太強大,自然也有缺點。目前也有很多APP針對Xposed做了一些限制導緻新版本直接不能打開,遇到這種請關閉模塊或者取消Xposed激活狀态嘗試。

  • Xposed官網訪問:有安裝程序模塊下載
  • Xposed國外論壇發布頁

目前android5.0以上才需要刷入框架補丁:

建議使用作者内置框架補丁MIUI,EMUI等系統可能需要專用框架

 

  • 手動安裝與卸載

很多同學都不知道xposed框架應該選擇哪些版本的文件來刷入,這裡做一個整理,大家根據自己的手機系統版本,CPU型号選擇對應的文件。卸載文件是不需要區分系統版本的,隻需要區分CPU的架構即可。Android8.0的xposed框架還在内測未發布,已經發布:

Xposed框架補丁文件與系統版本和CPU對應關系
CPU架構 ARM32 ARM64 INTEL X86
CPU舉例 骁龍805,801,800 骁龍810,820,821,835,652,聯發科P,X系列 Z 8350/8770
機型舉例 LG G2,ZUK Z1等 LG G2,ZUK Z1等 多數為平闆,小米平闆 2
Android系統版本 SDK level ZIP文件命名方式:XPOSED-版本-SDK LEVEL-CPU架構.ZIP
Android2.3 10 無官方版本
Android 4.0 15&16 官網已基本不再維護,可通過Xposed installer v2.7版本安裝
Android 4.1 16
Android 4.2 17
Android 4.3 18
Android 4.4 19
Android 5.0 21 xposed-v87-sdk21-arm.zip xposed-v87-sdk21-arm64.zip xposed-v87-sdk21-x86.zip
Android 5.1 22 xposed-v87-sdk22-arm.zip xposed-v87-sdk22-arm64.zip xposed-v87-sdk22-x86.zip
Android 6.0 23 xposed-v87-sdk23-arm.zip xposed-v87-sdk23-arm64.zip xposed-v87-sdk23-x86.zip
Android 7.0(已發布) 24 xposed-v88-sdk24-arm.zip xposed-v88-sdk24-arm64.zip xposed-v88-sdk24-x86.zip
Android 7.1(已發布) 25 xposed-v88-sdk25-arm.zip xposed-v88-sdk25-arm64.zip xposed-v88-sdk25-x86.zip
Xposed卸載 Xposed框架卸載(無需區分Android版本)

 

 

 

收集于網絡文章,表示感謝。

 

 

  • 我的微信
  • 這是我的微信掃一掃
  • weinxin
  • 我的支付寶
  • 這是我的支付寶掃一掃
  • weinxin
mandfx

發表評論

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen:

目前評論:20   其中:訪客  16   博主  4

    • avatar 飛龍 0

      有沒有bug,會不會像其他miui8那樣子造成miui數據錯誤導緻手機無法使用,進不了桌面

        • avatar mandfx Admin

          @飛龍 不會 不兼容的模塊不建議使用

        • avatar Lition 1

          一直出錯

            • avatar mandfx Admin

              @Lition 什麼出錯了

                • avatar Lition 1

                  @mandfx 模塊打開就錯誤報告

                    • avatar mandfx Admin

                      @Lition 什麼模塊 我這邊好測試下

                        • avatar Lition 1

                          @mandfx qq和微信的撤回模塊

                  • avatar vhbg 0

                    昨天刷過後,接收不到運營商短信

                    • avatar 小惡魔 0

                      樂視max2 框架安裝不上

                        • avatar mandfx Admin

                          @小惡魔 miui嗎

                            • avatar 蘑菇科技 0

                              @mandfx max2miui8你出的那個最新版xpossed安裝之後顯示未激活狀态無法使用

                                • avatar 岸上 9

                                  @蘑菇科技 我和你一樣,點擊自帶的安裝xp時無法完成,重啟很多次也是一樣

                            • avatar qq583961076 0

                              我的樂pro3刷了你的miui8的包點開 炫設置-輔助 看不到安裝XP的選項 隻看到一個灰色的XP工具箱 然後有一行小字“需先點擊安裝XP框架”方便的話麻煩加我qq583961076告知一下解決方法 已經打賞過了 謝謝!

                              • avatar 匿名 9

                                樂pro3刷的miui8xz框架用不了,自己安裝後移動數據就用不了了

                                • avatar 憂傷禦司 0

                                  樂視Pro3刷成MIUI8的都裝不了框架

                                  • avatar 匿名 9

                                    存儲路徑置換不生效
                                    怎麼辦?

                                    • avatar 正兒八經一青年 0

                                      xp不能激活,就是炫設置裡面的那個,

                                      • avatar 箫雲州 0

                                        樂視max2 xp 框架總是顯示未激活!什麼辦法都試過!

                                          • avatar 匿名 9

                                            @箫雲州 我的也一樣 樂視max2 xp怎麼裝都裝不上!!!

                                          • avatar CoNasTin 0

                                            可以單刷88.0版的xp框架嘛 如果可以能不能發一下包 其他版本的兼容性不太好 很多模塊不能用